AO

How to enable in a forum channel

FHFlorian Hockmann5/24/2023
I want to enable Answer Overflow on our Discord Server, but am currently failing to do so unfortunately :/ The Quick Start of the docs tells me to post /channel-settings in the channel to enable it (after inviting the bot to the server). But how do I do that in a forum channel? I tried to create a new thread there where I just used that as the title and the first message, but nothing happened. Is there some other way to post such a command in a forum channel or is there maybe a completely different problem?
RRhys5/24/2023
Hi! Sorry about the confusion with it, for managing the settings of a forum channel you have two options: 1. Make a new post like the one we’re in, and then as a message in that post use the /channel-settings slash command 2. From a normal text channel, use the /channel-settings command and pass in the forum channel you want to enable the settings of as an argument
No description
No description
FHFlorian Hockmann5/24/2023
Thanks a lot! That solves my problem. I guess this wasn't really a problem with your bot, but with how bots / slash commands work in a forum channel in Discord in general
RRhys5/24/2023
Yeah it’s a bit of a confusing UX at first, we’re working in making the onboarding clearer - feel free to send over any other questions Once you enable indexing it’ll take up to about 24 hours to see content, it starts from the beginning of the channel and works it’s way forward

Looking for more? Join the community!