Blåhaj
Blåhaj13mo ago

Error marking messages as answer

No description
No description
17 Replies
Blåhaj
Blåhaj13mo ago
No description
No description
Blåhaj
Blåhaj13mo ago
No description
No description
Blåhaj
Blåhaj13mo ago
all those were at least 12 hours or more ago
Rhys
Rhys13mo ago
@mwlica could you link to the pages that’s occurring on please? Thanks
Blåhaj
Blåhaj13mo ago
Answer Overflow
“There was an error talking to the database” - Someone's x Waya
Bot randomly stopped working and says “There was an error talking to the database”.
Rhys
Rhys13mo ago
Ah it’s since the bot isn’t able to send the solution id question id message If you make sure the bot can send embeds and messages it’ll work
Blåhaj
Blåhaj13mo ago
because I delete that one it looks ugly in chat
Rhys
Rhys13mo ago
Yeah it uses that to get the solution id and message it’s when indexing
Blåhaj
Blåhaj13mo ago
why isn’t that stored in a database
Rhys
Rhys13mo ago
It is stored in a database as well
Blåhaj
Blåhaj13mo ago
then why not use it from the database lol storing data in a chat the website relies on isnt really a good thing to do
Rhys
Rhys13mo ago
I’m aware of that it’s just from when it was implemented originally from a while ago, hasn’t really need to be redone since then The main thing was originally it was a bit of a pain to figure out what needed to be indexed next, and so when you marked the solution of a post if it’d add that to the database, then it’d make it more difficult to figure out what posts between that one and the last one that was indexed were It’s easier to do now I just haven’t gone thru and updated it
Blåhaj
Blåhaj13mo ago
let me know when the issue is fixed
Rhys
Rhys13mo ago
Will do, it’ll be about ~4 weeks until I’m back from vacation and I can work on it
Blåhaj
Blåhaj13mo ago
okey